Interqual Delays and Poor Performance
Incident Report for Aerial
Resolved
Change Healthcare reported the issue resolved at 7:53pm last night. Systems should be functioning as normal.
Posted Jun 14, 2023 - 07:13 CDT
Identified
Change Healthcare has communicated that InterQual Cloud users are experiencing long delays and poor performance while accessing the application and searching for subsets. They have identified the issue and are working towards a solution. We will communicate as we receive updates.
Posted Jun 13, 2023 - 10:32 CDT
This incident affected: Aerial Complex Care Management®.